Home Forums Game Frame Wi-Fi Adapter Issues with Firmware

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #3638


    I got my WiFi chip on Friday 24th Feb.

    I plugged the chip into my desktop Win10 PC via USB. Had no issues getting Photon app to work, connected to the chip, got it flashing an LED in 5 mins. Went to the “Game Frame WIFI Device Manager”, selected my chip. I had downloaded the most recent firmware:
    –> gameFrameWifi_20161211.bin

    Selected firmware, update. The device manager said it said it would restart, but I left it for about 10 minutes, no change. I figured it must have finished so unplugged it, slotted it into the GF and….nothing. Power on/off, a small scatter of LED’s would randomly light up.

    Eventually figured out the firmware had not finished installing so the chip went into safe mode. Knowing nothing about this stuff I went down the rabbit hole of trying to enter DFU mode, re-flash firmware, reset public keys, nodeJS command line, Zadig, CMD prompt photon codes etc etc

    Long story short, after 10 hours I got it back to fresh state. I assumed the USB cable I’d used was the fault, so used one I’d read was ok (XB1 pro controller braided cable). I selected the most current FM again, and…safe mode…again.

    Took 10 mins to follow same steps to recover the chip. This time I tried the next most recent firmware:

    Flashed in a few seconds, restarted. I unplugged USB cable, slotted chip into my GF, and bam! It’s working perfectly.

    I don’t get what happened, I don’t see any complaints about the current firmware, so no idea why I only had success with (T-1) release.

    Anyone have any ideas?

    Jeremy Williams

    Hi Richard,

    If I had to guess, I don’t think the firmware was properly downloaded. GitHub doesn’t make this really straight forward, but try using this link instead:


    Extract that and see how the file size compares to the one you tried. I suspect it’s bigger?… Then just repeat the flashing process with the file I provided and see how it goes.

    P.S. By the way, you don’t ever need to plug the Wi-Fi Adapter into USB. That’s just to give it power, which the Game Frame also does.

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Wi-Fi Adapter’ is closed to new topics and replies.