Home Forums Game Frame Hardware Modding Multiple "declared in this scope" errors DIY GameFrame

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #4394

    Hey everyone,

    I’m new to Arduino and so I am just beginning to learn to understand whats happening in the code, so please be patient with me.
    I’ve got a problem with getting the sketch for the GameFrame V1
    compiled. Im unsung Arduino IDE 1.8.8., the sketch and the needed
    libraries from GitHub. As soon as I want to compile the sketch I get
    multiple “XYZ was not declared in this scope” errors (for VerboseOutput,
    statusLEDState, buttonPressed, buttonEnabled, etc.). I’ve tried to
    compile the sketch on my Mac and PC, tried to re-install Arduino IDE,
    deleted and re-downloaded the needed libraries but nothing seems to work. Maybe I’m just not noticing a small detail which could help, but for now, I’m too confused to get an idea of what to do. I put the whole error code in the attached file.
    Maybe someone can help?

    You must be logged in to view attached files.
    Jeremy Williams

    This is definitely not a beginner project, but I admire that you’re giving it a try. The V1 source packs the Arduino Flash ROM to the absolute max, and I believe recent versions of libraries require too much space. You could try making a Game Frame V2 — probably a little easier since you can use a Teensy 3.2 with plenty of Flash storage. Just make sure you use APA102 LEDs.


    Hey, thanks für the quick reply. I realized the complexity of the Project a little too late, I already printed the parts and got the required parts in the mail. I‘ll follow your advice and get me a Teensy. Maybe I‘ll be successful when I follow the well documented guide from fischoderaal on imggur (https://m.imgur.com/a/Wp1VR). I‘ll keep you updated. Have a good day!



    I have exactly the same issue with the source code.
    Something in the declaration part seems to make problems, so the “void setup()” section isn’t recognized properly by the compiler.
    Probably the libraries are not correct.

    To solve it, I made a new project in Arduino and adapted your code step by step into my project.
    I made my own loops to crawl through the SD card and I managed to display the bitmaps I bought. When it comes to Inifile integration the sketch is not working anymore.
    I just declare the IniFile and it crashes.

    Additionally I switched from Arduino Nano to Teensy 3.2 now.
    But the code doesn’t compile anyway. (expected unqualified-id before ‘void’) in declaration of void setup(void).

    Do you have a more detailed list of library versions needed?

    Is it possible to adapt the V2 code to W2812 LEDs?
    I would really appreciate your help.

    Best regards and my respect for this cool project.

    Matthias from Germany

    Jeremy Williams

    I’m afraid I don’t have a list of library versions, but it might help if you paste your entire debug console into a pastebin or something and link to it. It is certainly possible to adjust the code to use WS2812b. Just make the necessary changed to the FastLED.addLeds line.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Hardware Modding’ is closed to new topics and replies.