Home Forums Game Frame Technical Support New gameframe, remote doesn't work, how to open?

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #3509

    Got my gameframe for xmas last week. It’s beautiful. But the remote doesn’t work. At all, no matter how close I am.

    First guess is the battery is dead. I’m trying to replace it.

    Dumb guy question: how do I open the remote? I keep trying to pull on the ‘release’ tab but nothing happens – it’s pretty well stuck in there.

    Thanks for any advice.


    Nvm, just figured it out.

    You have to squeeze the left side of the release tab toward the middle and then pull. I guess that’s what the little diagram was trying to tell me.

    Jeremy Williams

    Hey Pcal. Sorry for the trouble. Fingers crossed that it’s the battery. Please follow up either way!


    Hey all, having the same issue with a (maybe) DOA remote? Swapped new batteries, still no go. It sounds as though the contacts for the battery are not contacting properly? (Shake remote, sounds loose). Was going to open it to find out but didn’t seem like it was meant to open up.

    Jeremy Williams

    It could be the remote, but I haven’t seen a bad one yet (although I haven’t seen one that makes sound when you shake it either!). On the other hand, it appears some Teensy boards aren’t providing enough current to the IR receiver, which means the Game Frame can’t read signals, but unfortunately this issue is not consistent between baords so it’s hard to troubleshoot.

    One thing you can do to rule out the remote is try programming the Game Frame to listen to another remote. Here are the instructions. Let me know how it goes.

    Note: I strongly recommend you update to the latest firmware, as it includes IR remote fixes.


    Firmware update tool:


    Unplug the Game Frame. Unscrew the four screws on the rear of the Game Frame and remove the cardboard cover. Notice the two buttons on the rear circuit board: MENU and NEXT. (You can always use those if the remote completely fails, and holding down MENU functions as hitting the power button.)

    While holding in the rear NEXT button, plug in the Game Frame. The screen will go through some screen & SD tests and then stop at an IR remote test. It looks like a stylized remote icon with three colored pixels inside a gray rectangle. Holding down any of the IR remote buttons should change the image on the screen until you release it.

    Now, you can teach Game Frame new IR codes so that it uses a different remote. While at the remote test screen, tap the NEXT button on the rear of Game Frame again. You should see the POWER icon with a red border around the screen. The red border means “recording.” Tap a button on your other remote control that you want to act as the POWER button. The screen should change to a MENU icon. Tap a different button on your remote, and finally do the same thing when the NEXT icon appears.

    It will return to the IR test screen where you can test your new remote buttons. If they work, you can press the rear MENU button to boot the Game Frame into normal operation and keep testing it out.

    If you ever want to use the original Game Frame remote again, you can go through the same process or edit the REMOTE.INI file on the microSD card inside /00system. You’ll see the original codes there that you can copy and paste into place.


    Hey Jeremy, thanks for the quick reply!

    I went through the steps above and here is what I came up with.

    The buttons on the board work perfect, so no issue there.

    I went to the diagnostic mode and checked to see if the remote was registering at all. It was! But the buttons were all off by one, counterclockwise. So it was registering like this:

    Red = Green
    Blue = Red
    Green = Blue

    I went through the reprogramming steps so they all line up now.
    Red = Red
    Blue = Blue
    Green = Green


    Something I did notice. When in diagnostic mode, the response of the screen to button press is instant. When back into booted mode, pressing menu usually takes a couple tries to get the menu up. Normal to have different behavior there?

    Thanks again for the help! LOVE having the Game Frame in our living room!

    Jeremy Williams

    The behavior should be the same in both areas, as long as you’re aiming the remote generally toward the top/front of the Game Frame screen. And your experience with everything be counterclockwise is awful strange. Did you update the firmware?


    Going to update firmware as well. Will have to report back after doing so.


    I also have a flaky remote.

    The diagnostic screens helped me, as I found out I had to squeeze the remote around the area where it says “Game frame” to get the remote to work.

    Jeremy Williams

    davenedde: Sorry you’re having remote issues. You mean you need to compress the remote to make the battery make contact? Haven’t heard that issue before, but it’s possible. Does it work consistently when you do that? Have you tried replacing the battery? Updating the firmware?


    Yes, I need to physically compress the remote to get it to work. Even then it doesn’t always work, I have to try different spots.

    I did replace the battery.
    I updated the firmware yesterday when I got the game frame.

    Jeremy Williams

    davenedde: I’m trying to ascertain whether the problem is with your remote or the receiver in the Game Frame so we don’t waste time sending the wrong replacement. Are you 100% certain squeezing the remote has an effect? That would certainly suggest the remote is faulty, but you said it’s not consistent.

    Do you have another remote you could use to re-program the Game Frame using the instructions earlier in this thread? Depending on your results we could likely tell if it’s the remote or the receiver.

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘Technical Support’ is closed to new topics and replies.