Home Forums Game Frame Technical Support Remote doesn't always register

Viewing 15 posts - 46 through 60 (of 60 total)
  • Author
  • #2969
    Jeremy Williams

    Great! One last update that should fix the previous button issue. I’ll get the code up on GitHub later today.


    Rather than showing the wrong signal it will just show no signal at all. Previously any repeat signal was accepted, and it would always repeat the last prime signal detected. Now it won’t accept repeat signals if there has been a 250ms delay since the last valid signal (prime or repeat).

    The remote record screen issue is acceptable. You may need to press a button twice, but at least it’s not accepting bogus signals. I’m also really happy it’s storing them correctly.

    Setting the clock is a better user experience all around and is better for everyone. I’m glad you provided the impetus to change it.

    Breakout is kind of random. If you hit on the center pixel it’s a 1:1 deflection. If you hit on the side pixels it deflects in that direction at a random angle. Speed increases with each brick hit. It is hard, but it is possible to beat. 🙂


    Yup, fixed the issue in remote test screen. I’m not seeing the wrong icon, only sometimes button is ignored. Tried recording mode multiple times, and it works fine as well.

    We still don’t know what was causing the issue in the first place, maybe some interference between LED display and IR remote when display is being updated?

    Not sure how the wiring is done, but the fact that the crash test screen is almost not impacted at all (no display updates), while others screen are (lots of quick display updates), tends to incriminate the LED drivers … ?

    Jeremy Williams

    Yeah, your guess is as good as mine as to the root cause. Thanks for bringing it to my attention. Code changes are reflected on GitHub now.


    Hi, i received my Game Frame a few days ago. Bought it at eboys store, because i’m from Germany. It seems i have got issues too with the IR remote. Sometimes it works fine, sometimes there’s nothing happening. Changed the battery, changed the Room and teached Game Frame a new remote as explained on the first side of this posting. Within the test-mode Game Frame always showed the right Icon while pressing the buttons on the new remote. After turning to normal-mode, Same problems as with the original remote. The IR Receiver is positioned right, as shown in the picture. My Game Frame is without WiFi, because unfortunately the wifi-modul is Not acailable in Germany. I’m no tekkie, so i am Not able to build my own etc.
    is there anything i can do to solve the IR remote-problem?

    I Love the Game Frame, already started to paint some new animations and pics, the remote works with pressing the Buttons a lot of times, but it would be cool to show the Game Frame to my Friends like “bam! You only have to press once and the magic starts.” And Not “oh wait….it will work just after….damn, only one more time…hm no, doesn’t work. Ah now! That’ the Game Frame!” “Wooooooow”

    With best regards from germany! Hoping for the Problem to be solved.

    You must be logged in to view attached files.
    Jeremy Williams

    Ack! I swear, it can’t be coincidence that almost all instances of this IR problem occur in Europe. I think it might be related to the different power standards. That said, eBoy has never reported any problems with the units they use.

    zytogeist, can you please verify that you’re running the latest firmware? I believe all of the ones eBoy has on hand have that pre-installed, but I could be mistaken. Here’s one way to test: Launch the breakout game. Press and hold NEXT to launch the ball and *while continuing to hold NEXT* quickly flick remote away from the Game Frame and then back at it. If the paddle stops moving, it’s the latest firmware. If it stops briefly when you move the remote away but then starts moving again once the remote returns, it’s the old firmware.

    We will figure something out! If you’re running the latest firmware, please email me (jeremy and this domain).


    Hi zytogeist!

    I live in Germany too and bought my gameframe directly from Jeremy. (Don’t ask me about to taxes… 😉
    I had some IR Problems too and after testing a lot of situations i solved the problem simply by changing a really new battery from Varta. (No cheap ones). Maybe that helpes.
    And by the way – I have to check my firmware too…
    Wifi would be a good upgrade, but there are noch modules available from eboy…

    If you want, contact me via E-Mail: brendelino@mac.com


    Thanks for your really fast response. Tested the brick-Game several times. I Hope i did it right. Choosed the Game and After clicking next and keeping it presssed the Game started. It seemed to me the paddle did Not stop moving. Did the Same with clicking once to start the game and clicking and pressing to Release the ball.
    How can i change to the latest Firmware, without the wifi?

    Tomorrow i will try to find a new battery, from Varta, the good stuff. Thought Living on an Island will Drive me into trouble one day, still some parts are Not available…tried several other Batteries of “No-Name” sellers.

    Jeremy Williams

    Just to be clear, you pressed and held the button, flicked it away so it’s not pointing at the Game Frame (so the signal isn’t “seen”) and then flicked back, and the paddle started moving again? If so, that’s the old firmware.

    You can find firmware instructions in the FAQ.

    Let me know if that solves your problem!


    Send you a we-transfer link to some Videos of my tries.
    Will buy a new battery and a micro-usb-cable tomorrow, since i don’t have any 🙁

    Thx for your Support Jeremy.i will report as soon as possible. Thx brendelino too!


    Jeremy Williams

    Wow, no micro USB cable. I feel like I could learn something from you. I regularly throw them away because I have too many.

    Your videos do indicate old firmware. Fingers crossed.


    Oh no 🙁
    I’m storing nearly all of the cables from every device i get, but there is no Micro-usb. That’s Crazy, isn’t it?
    You can send ne one and while you pack a Package anyway, add a wifi-module 😉
    Just kidding, but is there any Chance of getting one from eboy in the nearer future?




    Status update:
    Got a micro-USB-cable, updated the firmware, see the video, and tried an other remote again. In Test-mode, while teaching the new remote, all three buttons always(!) work, as soon I leave to normal mode. The new remote the same as the original remote.

    The problem still exists. Turning the game frame on, out of “stand by” always works(!), but it worked befor updating the firmware too. I still have to press the buttons 20-40 times till game frame reacts, no matter which button.

    Jeremy Williams

    Well, you flashed correctly (thanks for the videos — it makes things so clear). I’ll followup in email.


    The remote is working perfect now. Thanks Jeremy for this great support 🙂

    Jeremy Williams

    For anyone wondering, we tried both swapping in a Teensy 3.2 and a Wi-Fi Adapter. The Wi-Fi Adapter worked (Teensy didn’t).

Viewing 15 posts - 46 through 60 (of 60 total)
  • The forum ‘Technical Support’ is closed to new topics and replies.