Home Forums Game Frame Technical Support Wi Fi adaptor problems

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #4003

    Hello, just got my Game Frame Photon Particle and I’m having problems with the wifi set up.

    When the photon is plugged in the game frame won’t turn on?
    I have tried to reset the photon and re do the setup of it as the Frame works fine with the original chip back in. But now my Photon keeps failing when i click that I want to claim ownership of it?

    I’m not sure how to reset the photon and start again with it?

    Any help would be great.
    Apart from that I love the Game frame!!



    Jeremy Williams

    Welcome to the forum, Andy. It sounds like you haven’t flashed the Photon yet, is that right? Which step in the setup instructions is causing trouble?


    Hello Jeremy,

    Firstly thanks for the quick reply… I am over in the UK so after posting my question went to bed having failed to sort it myself.
    I am a complete beginner in this but a lover of pixel art, so it is great to know there is a forum for support.

    Right, now I followed the set up as best I could but something has gone wrong somewhere along the line. Here’s what I did…

    Photon plugged in to laptop and powered on, used the Particle app on my iphone, found it, linked it to my home wifi with no problems, got it to flash a light and gave it a name.

    Then loaded up the firmware uploader, logged into my particle account and found my device from the drop down and clicked the upload of firmware.

    All seemed to be fine, I left it running for a good while, but recall not getting any message saying it was complete, it just said the device would restart once done.
    I gave it about 8 minutes then assumed it was done, as I was taking out the sd card at this point.

    On the SD card, excuse my basic questions, but I wasn’t sure how to ‘extract’ the new firmware download onto it?
    I simply created a ‘wifi’ folder in the ’00 system’ folder and then dragged the downloaded firmware file into it.
    Is this ok for the SD card side of things?

    Anyway, having popped the SD back I then swapped the Photon into the Game Frame and put the power cable back. The Game Frame had a red light on the back and a blue light on the Photon but would not power on with the remote????

    I swapped the original chip back in and it is working fine.
    So thought I would re do the set up for the photon…..

    Things got worse here….
    My Photon was showing on the app but I couldn’t tinker with it or make it flash etc?
    So I decided I should delete it from the app and start a fresh!

    The Photon had a blue light on and I got it into safe mode by holding setup….
    Found it on the app… linked it to my wifi and then it goes through a check list.
    I clicked ‘reclaim this device’….
    Everything is ok on the check list, connection to internet etc…
    Then it fails and says unable to claim ownership of this device???
    So I retried and didn’t click to claim ownership and the result was the same.

    I’m not sure why this is?
    Is it already linked to me or the Game Frame?
    I don’t know how to get past this as if I go to the software downloader from the link and log into my Particle account there isn’t any devices in the drop down list to update??

    Apologies for my waffle and for asking such basic questions but I got into a right pickle last night and couldn’t work out what to do…. it doesn’t take much to scramble my novice mind…. so any advice you can offer would be great.

    Meanwhile the Game Frame is an awesome product and I am enjoying all the e boy art on it. It is currently sat next to my Alexa device, so I can’t wait to hook them up together!

    Again many thanks for the support.



    Also I noticed my Photon has the circuit board with USB labelled on it at the opposite end to the actual USB socket on it. Which is different to the one shown on your site?
    Probably nothing but just thought I’d mention it and post a pic.


    You must be logged in to view attached files.

    Just further to the above re the SD card extraction…
    I just found the zip file!
    So deleted the wifi folder and the bin file i had created and right clicked and extracted it as per your instructions….
    Doh… couldn’t see the woods for the trees.

    Unfortuneatly it hasn’t solved the Photon issue.
    I still just get a red light on the GF and a blue oin the PP when i plug the power in and can’t turn it on??

    Jeremy Williams

    Whoa! Your Photon was indeed installed REVERSED! Your board is blue — this means you bought from eBoy, correct? If so, please contact them for a replacement. (I didn’t make their boards — they sourced their own assembly.) I’m sure that will solve your problem. If not, please let me know and I’m happy to help you sort through this further.


    Well that is a relief!!!
    No wonder I couldn’t get it to work!?
    I have just sent eBoy an email detailing this and a couple of pictures and screen shot of my/your forum comment.
    I have asked them for a replacement and advised I can send this faulty one back.

    I’ll let you know when they get back to me.

    Thanks again for the support.



    I got a reply from eBoy today saying they would send out a replacement wifi adaptor quickly. Which is great news!




    Well eBoy have replied saying they will send me another Photon. However they have also emailed to say the picture I sent them of my ‘reversed’ one is the same as the ones they have in the office and they are working ??

    So I don’t understand if the chip is faulty or just different to that in the picture?

    Anyway whilst waiting I have managed to flash my Photon and this has allowed me to complete the set up procedure again.
    This time I made sure to pay attention when uploading the game Frame firmware onto it.
    It took only a few seconds before the photo restarted and had a blue light on the D7 bit and a white light in the centre. Pretty sure it did this last time?
    Anyway I popped it back into the GF with the actual USB PORT to the right and put H power cable in. As before all I get is a blue light on the back of the chip and a red light on the back of the GF?
    It won’t turn on with ththe remote?

    Is there anyway I can check the Photon chip and it’s firmware before i plug it back in?
    Does the fact I’m able to flash the Photon and seeming upload firmware mean my Photon all be it built different to those Show is not faulty?

    Sorry about all these questions!?

    Jeremy Williams

    You’ve probably flashed the firmware just fine but it can’t talk to the Game Frame because it’s installed backwards on the blue Photon -> Teensy conversion board. It needs to be installed with the USB port next to the word USB like in the product photo.

    I’m sure eBoy doesn’t have it installed backwards and working. There must be some confusion. 🙂

    Game Frame Wi-Fi Adapter


    Well the new adaptor arrived and I got it set up first time!
    Just busy uploading pics and having a play around!
    Thanks again for the support and advice!
    Here’s a pic of both my adaptors…. top one being the new one that does the job!


    Can’t seem to upload the pic off my phone. But needless to say the USB port and badge are both on the same side! As per the pics on your site!

    Jeremy Williams

    Great news! Glad to hear it. When you get a chance, please let eBoy know it’s working too.


    Yes I’ve already sent them a photo of the two different photons and asked about posting the faulty one back.

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘Technical Support’ is closed to new topics and replies.