Home Forums Game Frame General Discussion Building my own GameFrame – Please Help!

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #2708


    my Name is Oliver and currently i’m trying to build the game frame in XL size with ws2812b LED Stripes as a birthday gift for my girlfriend. i have done the acrylic case and everything i need for hardware, except for the micro controller…
    I first started with the combination ws2812b <—> Atmel atmega 328 (game Frame v1) which worked like a charm. But now i would like to get it working with the teensy-lc. So my problem right now is the following:

    When i compile the sketch for the teensy-lc i receive an error:
    “Fehler beim Kompilieren fΓΌr das Board Teensy LC.” which is German, because thats my mother language (sorry). Translated it says “Cant compile for the Teensy-LC … there is a failure”

    What i tried:

    1 . I can compile the sketch for the teensy 3.1/3.2 without problems, but i don’t own a teensy 3.x at the moment and have to get it working with the LC within about 24 hrs

    2 . When i compile the sketch for the teensy 3.1/3.2, the sketch tells me, that it uses 70.612 Bytes of memory, which in my mind is to much for the LC…i’m not sure….

    So my only hope is, that i’m useing wrong librarys which are to new/big to fit on the LC and that someone maybe PLEASE can give me a bundle of librarys working for my case.

    I have to get it working until Sunday somehow so it would be such a nice, perfect, great Help, if you guys could help me with this problem!

    Thank you so much in advance!

    BTW: On Github (https://github.com/Jerware/GameFrameV2) i found the information, that the firmware was compiled under arduino IDE 1.6.3 . I can’t get the teensyduino software to work on this old release. It only supports 1.0.6 , 1.6.5r5, 1.6.7, 1.6.8, 1.6.9. I’m currently using IDE version 1.6.9.

    Best Greetings from Germany

    Currently 01:38 AM

    Jeremy Williams

    The code really pushes the Flash memory limit. Try Teensyduino v1.22 and see if that does the trick. If not, let me know the compile size for Teensy 3.1.



    Thank you SOOOOOOOO MUCH!!!!!!! It seemed to do the trick! YYEESSSS!

    Sketch uses 63,300 bytes (99%) of program storage space. Maximum is 63,488 bytes.
    Global variables use 5,348 bytes (65%) of dynamic memory, leaving 2,844 bytes for local variables. Maximum is 8,192 bytes.

    Because of your support i now can sleep and continue work tomorrow, so again THANK YOU!!!!

    Thank you for the Game Frame!!!

    Jeremy Williams

    Great, glad it worked. I’ve added a link to Teensyduino 1.22 on GitHub in case others run into the same trouble.


    Sadly i ran into a new problem. The leds just flash one time and then stay off all the time.

    With an example sketch from the fast led library (included in Teensyduino 1.22) the same happens.
    With the newest fast led example sketch works fine….

    but with the newest fast led library teensy runs out of flash memory.
    “arm-none-eabi/bin/ld.exe: region `FLASH’ overflowed by 156 bytes arduino”

    Can you help me out?

    Jeremy Williams

    Sounds like an initialization issue. Are the sketches the exact same? If not, have you tried the sketch that works with the library that fits into RAM?


    The sketches are exactly the same.
    I changed SK9822 to WS2812B
    // LED Init
    FastLED.addLeds<LED_TYPE, DATA_PIN, CLOCK_PIN, COLOR_ORDER>(leds, NUM_LEDS).setDither(0);
    FastLED.addLeds<LED_TYPE, DATA_PIN, COLOR_ORDER>(leds, NUM_LEDS).setDither(0);

    I also tried: FastLED.addLeds<WS2812B, 2, GRB>(leds, NUM_LEDS).setDither(0);

    Nothing helps. πŸ™

    Jeremy Williams

    I’m compiling with FastLED3.1.2pre. What version are you using?

    By the way, as a workaround you can comment out breakoutLoop(); from loop() and get the version that works to fit into Flash, at least until you figure out what’s wrong.


    I also builded my own Gameframe with a Teensy Lc and want to use Neopixels. Everything is working for now but the Pictures are mirrored. My first Led begins in the upper right corner. I didn’t find any way to correct this with the FastLed Library.

    Maybe someone can help me?

    Jeremy Williams

    If they start in the upper right it should be normal — that’s what the Game Frame does. In any case, you can mess with the getIndex function to change it. It’s around line 1724.


    thanks for your fast reply. I bought the eboy Animations and changed every x to y and every y to x in this function. Now everythin is correct instead of the game. The baar scrolls up and down on the left but this is a minor glitch πŸ™‚


    I’ve also got problems. For me it does not even compile, even though I’m using Arduino IDE 1.6.3 and TD 1.22 as well as the included libraries.

    I tried it three times:
    1. main computer
    2. old computer (first time I used Arduino IDE on that PC)
    3. Virtualbox VM (brand new install)

    The errors are always the same. See attached file.

    Anyone understand where the errors are coming from? Otherwise, I would be grateful if someone could send me the *.hex where

    #define LED_TYPE SK9822

    is changed to

    #define LED_TYPE APA102

    ? I’ve got a prefabbed 16×16 APA102 matrix I’d like to use.

    You must be logged in to view attached files.

    Hello everyone
    i also need assistance in game frame.
    best regards


    Alright πŸ™‚ Had the time to try again and it seems to be working now.

    But it was mirrored vertically so I adjusted the function getIndex function. There is now a bool you can put to true if it is mirrored.

    I also adjusted the LED type to APA102. you can find the ino here and the HEX here.

    I also created a quick protoboard that already incorporates the WiFi-adapter. Use at your own risk and double check the connections. You can use BlackBoard designer to open the file. Otherwise see here: top wires, bottom wires, parts (the two switches are on the underside), altogether. Just imagine that the pin headers are actually pin sockets…


    Hm, there still appears to be something wrong. When I press “Menu” short the menu won’t open. I have to press several times for it to appear and then it is very hard to set something.

    The only way to adjust something is to stay in the menu item before the setting I want to adjust, push the “next” button to adjust the setting I want to change but as soon as I press “menu” again he will also press “next” one last time, changing the setting again. Is this the way it is intended?

Viewing 15 posts - 1 through 15 (of 20 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.